PSP port bugs

View previous topic View next topic Go down

PSP port bugs

Post  MAN-biker on Mon Aug 23, 2010 2:25 pm

Lands of Lore CD
PSP 1.2.1svn52301

I think there is a "controls error" in this game: to "TURN RIGHT" action we must press [RIGHT SHIFTER]+UP (instead of [RIGHT SHIFTER]+RIGHT).
But "TURN LEFT" action works correct: [RIGHT SHIFTER]+LEFT.

By the way, is it possible to remap some controls in SCUMM VM in this game?
It`s mush handy to control this game for example, [LEFT SHIFTER]+[RIGHT SHIFTER] as main menu or ESCAPE, instead of current "[LEFT SHIFTER] only" but [LEFT SHIFTER] as "MOVE LEFT" and [RIGHT SHIFTER] as "MOVE RIGHT" and [LEFT\RIGHT D-PAD] as "TURN LEFT\RIGHT".

Thank you in any case.

P.S.: OGG tracks still works fine!
avatar
MAN-biker

Posts : 27
Join date : 2010-08-22
Age : 44
Location : Russia, Moscow

View user profile http://manbiker.narod.ru

Back to top Go down

Re: PSP port bugs

Post  Pix on Tue Aug 24, 2010 1:03 pm

I did some LOL controls a long time ago but what is on there now is all part of the official build so its probably one for the scummvm team rather than me. Its worth mentioning on the PSP forums on scummvm.org although I'm not sure if this would be an issue with the PSP build or the kyra engine itself.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

Re: PSP port bugs

Post  Scarlatti on Fri Oct 01, 2010 8:30 am

Just out of curiosity, is the copy protection still enabled for most games on the PSP port? It must be a bit annoying to keep saving games after the copy protection screen, to bypass them the next time you want to play. Of course, on the PC the documentation is always one alt-tab away. I would imagine that some of the Sierra games are downright unplayable: something like Conquest of the Longbow has the copy protection integrated as puzzles in the main game. Not very practical, to carry around a large manual with your portable console. Smile
avatar
Scarlatti

Posts : 16
Join date : 2010-08-23

View user profile

Back to top Go down

Re: PSP port bugs

Post  Pix on Fri Oct 01, 2010 10:11 am

It's still on all the Sierra games on the last build I did anyway. I was expecting it to be sorted out by now. The PSP isn't that practical for some of these games apart from that. Arcade sequences like the robot fight in SQ3 are more or less impossible with the virtual keyboard. It's much better suited to the point and click games.

There are also performance issues on the PSP with some SCI games. You can end up with several ogg's streaming simultaneously which can make things grind to a halt. I'll probably need to implement a voice limit of a couple of tracks for the PSP eventually. I need to track down exactly what the bottleneck is, I think it's memory card access but haven't tested this out yet. I've hardly used the PSP for playing any of these games in ages. I'd be way more likely to use my phone. I gather the official Android port should be out this month so I'm looking forward to giving that a go assuming I can figure out how to compile it.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

Re: PSP port bugs

Post  Bluddy on Mon Nov 15, 2010 5:10 am

Just to give a heads up, the PSP port now has support for movement while the keyboard is displayed (using the nub). It also supports LOL mode and I even put in an image reader so you can view whatever you want to on the PSP while playing (walkthrough or whatever).

Download the subversion build at www.scummvm.org and check out the readme file for directions.

Also, pix -- you'll probably need to update your music patch since the audiocd code was changed.

Bluddy

Posts : 2
Join date : 2010-11-15

View user profile

Back to top Go down

Re: PSP port bugs

Post  Pix on Tue Nov 16, 2010 3:43 am

I'd noticed the changes but not tried them out yet, the image reader is a nice addition. I'm busy with other things at the moment but will try to do a new build this week if I get the chance. I've been looking into doing an Android build which I got running but I'm unimpressed with the performance, even without adding the additional load of playing oggs so I think I'll leave that one for now and stick to the PSP.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

Re: PSP port bugs

Post  Bluddy on Tue Nov 16, 2010 4:23 am

Regarding the ogg issue, I'm not sure what's causing the bottleneck either, but you can try see if it'll work better with MP3s. If it's a CPU load issue, that should do the trick. If it's a memory stick reading issue, you may want to try increasing the size of the read buffers in backends/fs/psp/psp-fs.cpp. I wanted to play with the sizes myself but haven't found an engine demanding enough to cause a change in performance.

Bluddy

Posts : 2
Join date : 2010-11-15

View user profile

Back to top Go down

Re: PSP port bugs

Post  Pix on Thu Nov 25, 2010 10:27 am

Thanks for the advice. Converting to mp3 removed all slowdown completely. I'll put up mp3 downloads for all the SCI1 and over games since they appear to be the only ones affected. I've updated to the new AudioCD Manager also. I'm glad to say it was just a search and replace job.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

can't add or run ANY game in latest build

Post  MAN-biker on Tue Nov 15, 2011 6:35 pm

Pix, help.
I just downloaded and unpack your latest PSP build (ScummVM-PSP r1759-g9c823aa-dirty) and can`t add or play any game, because SCUMM VM hangs up and turn off my PSP.
Previous builds works fine.
avatar
MAN-biker

Posts : 27
Join date : 2010-08-22
Age : 44
Location : Russia, Moscow

View user profile http://manbiker.narod.ru

Back to top Go down

Re: PSP port bugs

Post  Pix on Wed Nov 16, 2011 11:46 am

I expect that you may just need to clear out the settings/files from the old version. It's not that likely to be anything I've done.

I see that the new version of scummVM came out this week so it's time I started working on the "final" version anyway. I'll start looking into that this week and get another version up at some point.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

Re: PSP port bugs

Post  Pix on Sun Nov 20, 2011 10:28 am

The new version is up if you want to give it a go. This one is definitely working on my PSP. Simon 2 should hopefully be stable now + SCI savegames load correctly.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

Re: PSP port bugs

Post  MAN-biker on Sun Nov 20, 2011 4:58 pm

Thanx, Pix! I'll try it ASAP!
avatar
MAN-biker

Posts : 27
Join date : 2010-08-22
Age : 44
Location : Russia, Moscow

View user profile http://manbiker.narod.ru

Back to top Go down

no luck :(

Post  MAN-biker on Sat Nov 26, 2011 5:45 pm

Hi, Pix. Sorry, still no luck with your build on my PSP.
I`ve tried:
- remove scummvm.ini at all
- disable ALL seplugins
but without success: when i try to add a game to scummvm, search a game folder and then click add button... flash card LED is lighting (NOT blinking!!!) some seconds and PSP turns off. The same thing if i try to run previously added game (i have tried many games, but result the same).
I thought it happens because of my "bad, not original memory stick" or PSP hardware\firmware (i've NOT tried run it on another my PSP or mem stick yet), but original 1.4.0 SCUMM VM PSP build from SCUMMVM.ORG site WORKS FINE (LED blinking and game adds OK and works good)!
Please help me, Pix, i LOVE your builds ant you music tracks for games!

avatar
MAN-biker

Posts : 27
Join date : 2010-08-22
Age : 44
Location : Russia, Moscow

View user profile http://manbiker.narod.ru

Back to top Go down

Re: PSP port bugs

Post  Pix on Sun Nov 27, 2011 1:58 am

You have to be doing something wrong. My guess would be that you haven't deleted out all the old plugins before copying the new ones in. It would cause exactly the behaviour you are describing if there was something left over from another version. Trying another memory stick wouldn't be a bad idea. You could also try installing it to a different directory. If that doesn't work try deleting all the plugins except one and see if you can add a game for that engine.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

solved!

Post  MAN-biker on Sun Nov 27, 2011 12:02 pm

Thanx. Pix, i already solve this trouble last night (i post my message here, go to bed with PSP, open file manager, found 4 old plugins from some previous installation, remove them and now all works fine).

By the way, tell me please, why those plugins doesn't exist in lates builds (as i remember, m4.plg and some other)? May be included in other files, for example, in scumm.plg?
avatar
MAN-biker

Posts : 27
Join date : 2010-08-22
Age : 44
Location : Russia, Moscow

View user profile http://manbiker.narod.ru

Back to top Go down

Re: PSP port bugs

Post  Pix on Sun Nov 27, 2011 1:36 pm

Glad you got it working. I've only included the default/stable engines in the build which is why there are fewer plugins.
avatar
Pix
Admin

Posts : 72
Join date : 2010-08-21

View user profile http://scummvmhacks.ezboards.co.uk

Back to top Go down

Re: PSP port bugs

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum